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1.0 System Description  
 

µBeam is a versatile measurement system, offering both analytical and graphical 
capabilities for sub micron beam measurement and analysis applications. This is a 
custom design measurement station composed of a CCD type beam profiler, 
supplemented with high magnification optics and the computing technology. 
This is a powerful beam diagnostics measurement system for real- 
time measurement and display of small CW or pulsed lasers in the  
sub-micron range, fiber optic and laser diode beam profiles. 
 
This is a software driver device that interfaces to any host PC computer, running under 
Windows XP, Win7, Win8 and Win10, via the USB port, to meet a wide range of automated 
laser analysis requirements in the laboratory, field or factory.   
 

          µBeam has applications in CD pickup, laser diodes, adjustment of pickup lenses and optics 
components, evaluation and testing of various light beam parameters, and any application 
where the quality and shape of the beam affects system performance and there is a need 
to analyze very small beams. 
The main parameters measured are: Intensity profiles, beam width, beam 
position and beam shape. 

 
The new µBeam system has an improved resolution and improved optical zooming, 
allowing a wide range of microscopic beams to be measured. The built-in motorized optical 
zooming greatly improves the beam finding capabilities, as well as the user convenience. 
The 470,000 pixels CCD allows improved measuring resolution. 

 

 

1.1 Copyright and Manual Notice  
This manual describes the operation of the µBeam System. 
Duma Optronics reserves the right to make changes to this manual and to the equipment 
described herein without notice. Duma Optronics has made considerable efforts to ensure 
that the information in this manual is accurate and complete. However, Duma Optronics 
will not be liable for any technical or editorial errors or omissions made herein or for 
incidental, special, or consequential damages of any nature resulting from the furnishing of 
the manual, or operation and performance of equipment in connection with this manual. 
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2.0 Precautions 
 
2.1 Handling of the Measurement Head & magnification optics 
- The CCD detector head should never be attached to the control unit unless it is turned off.  
- The magnification optics is very delicate, handle with precaution 

 

 

2.2 Laser safety precautions 
This instrument is most commonly used with laser sources. The operator should observe all laser 
safety procedures and precautions when operating this device. In particular it should be noted 
that a small portion of the laser beam incident on the detector head will be reflected. This can be 
hazardous and the operator should beware of both specular and diffuse reflections. The operator 
should exercise special care when working with invisible laser radiation.  
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3.0 Theory of Operation 
 

In the modern laser world, focused beams are smaller and smaller and there is a developing 
need to measure and characterize those beams. Although theory predicts the behavior of a beam 
quite accurately, manufacturing constrains such as tolerances in lenses and mirrors have a 
strong influence on the actual beam size. 
 
Consequently, it is crucial for laser manufacturers, especially on those applications requiring sub-
micron accuracy to be able to accurately measure the laser beam width at the focal point. 

 

 

Defining Beam Width 
The commonly used definition of beam width is the width at which the beam irradiance has fallen 
to some percentage value when compared to the peak (100% value). In order to allow maximum 
flexibility this parameter can be set by software means in most of the valuable beam profilers. 

 

 

CCD Camera based Beam Profilers 
A CCD camera consists of a two-dimensional array of pixels. The impinging laser beam on a 
CCD based profiler leaves an “electronic footprint” which is linearly dependent on its intensity 
distribution. 
The intensity distribution is then recorded pixel by pixel, analyzed and displayed as two, or three 
dimensional contour plot. 

 
Unfortunately, this measurement technique works as long as the examined beam is significantly 
bigger than the CCD’s pixel size (about 5 µm). 
This fact limits the use of such a system to measurement of beams, which are bigger than 50 µm. 
 
In order to overcome this limitation, a special beam profiler was developed, operating in a 
similarity to a microscope. 
A high quality lens is used to magnify the sub-micron beam by a factor of X100 onto the surface 
of a high quality CCD camera. In order to facilitate initial beam acquisition into the field of view, 
the system is equipped with a built-in zooming optics. 

 
The analyzing software processes the data and displays results with a nanometric resolution. 

 
 

Dynamic Range 
One of the main obstacles encountered when working with a CCD is its limited dynamic range. 
The powerful software and electronics overcome the dynamic range limitation of the camera by 
software control of gain and electronic shutter. 
Due to its pixel-like construction and low noise feature, the µBeam is still useful in extremely low 
light conditions as well. 
 

Optical Zooming 
When equipped with an objective of x100 and at its minimum field of view, the µBeam USB 
system will see an object of 55x44µm max (using Video resolution of 720x576). The pixel size at 
the objective plane is 0.076µm. 
The relatively small field of view at maximum magnification posses significant difficulties in the 
initial beam finding.  
In order to over come this limitation and to increase the field of view the system is equipped with 
a zooming optical magnification from x25 to x1. The maximum field of view at minimum zoom is 
about 150x130µm.  
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Main software features: 
1. Graphical presentation of a laser beam in 2D. 
2. Three ROI’s (Region of Interest) user-selectable. 
3. Centroid and beam width profile calculation to sub micron accuracy. 
4. User adjustable dynamic range by controlling the built-in electronic shutter speed and 

gain. 
5. Performs Test analysis (Absolute distance between user defined Points)  
6. Customer set pass/fail test criteria  
6. Measures CW or pulsed beams. 
7. UV option. 

      8.    Real time beam measurements:   Beam size at 3 clip levels with Gaussian fit 
Total intensity (sum profile) along XY axes  

 XY profiles selectable by anchor point & rotation  
      9.  Real time position measurements   XY centroid position 
     10. Data logging with detailed statistics  
     11. Video with playback    
     12. Save / View images 
     13. Digital Zooming 
     14. On line instructions and help 
     15. Calibration - Pre factory calibration for accurate measurements  
     16. Motorized optical zooming  
     17. Coma aberration calculation and display (for testing optical disk systems) 
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4.0 Specifications 
 

Item Specification 

Camera and Magnification  

Camera type CCD 1/4” format, with 470,000 pixels 
 

Spectral Response 350 - 1100nm, (190-1100nm optional) 
 
Infinite conjugate objectives:  
X100, x50, x20, x10, x5 
  
For fast beam finding the system is equipped 
with a zooming lens for observing large areas 
 
Built in removable NG10 filter 
 

 
Infinite conjugate objectives:  
X100, x50, x20, x10, x5 
  
For fast beam finding the system is equipped with a 
zooming lens for observing large areas 
 
Built in removable NG10 filter 
 

Configuration 
 

Tube type zooming microscope equipped with M6 
mounting thread adaptor   
 

Dimensions: 163.5 mm (L) X 83mm Diameter (without objective 
and base) 
 

Weights: 1.1 Kg without base 

  
Lens Working Distance (W.D.): 6.0mm (for X100), 13mm (for X50), 33.5mm (for 

X10), 20mm (for X20) 

  

System Performance  with Software:       
Minimum measurable beam size 0.5 µm for 
X100 objective  
 
Maximum frame rate           25Hz (CW lasers) 
Max refreshment speed      10Hz (CW lasers) 

 

 
* Repeater USB (5m long) is provided as optional item for cases where longer distance 
from MicroBeam head to host computer is required. 
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4.1 Mechanical drawing 

 
 

 
 
 
 Figure 1: Mechanical drawing  
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5.0 Getting Started 
 
Setting Up for a measurement 
This chapter provides a basic instruction for setting up the measurement cycle. 
Before you can accurately perform a measurement you need to bring the laser beam into the 
measurement area, by doing the following the herein described procedure. This operation is a 
very delicate one, since the total measuring area of the CCD (after the magnification) is about 40 
µm. 
 
For users that need various beam measurements it is strongly suggested to mount an X-Y 
Table beneath the pickup lens basis, for an easier alignment. 

 
1. Install the laser in front of the system’s objective lens (See Figure I). 

 
2. Use the system’s zooming function for course adjustment. 
(See µBeam Main Functions, chapter 6.0).  
 
Find the beam at the minimum magnification. Focus the beam by using some adjusting  means 
(manipulators). 

 
3. Slowly change the magnification by moving the zooming lens to its maximum position, 
By using software function called Optical Zoom, activated through the ToolBar icon. 
In order to get the right magnification (X100) perform a measurement while refocusing for best 
results. 
The measurements are calibrated at the following zoom ratios: X25, X1.7D, X2D. 
In this magnification region, the optical zoom icon will turn from Red color to Green color, see as 
follows: 
 

 Optical zoom 
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6.0 µBeam Main Functions 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Software features  
 
This section covers the basic layout of the system software. 
When the µBeam for Windows is started, the main window display appears. This window consists 
of display and control elements similar to most Windows applications along with elements specific  
The main elements of the µBeam window interface are as follows: 
 
Title Bar 
The Title Bar displays the name, µBeam. 
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Menu Bar 
The Menu Bar lists menus available for the µBeam. The menus listed in the Menu Bar contain 
commands that allow specific actions to be performed, other sub-menus or dialog boxes to be 
displayed which provide various controls of such functions as graphics, analysis, configuration 
setup, etc. 
 
Tool Bar 
The Tool Bar consists of various icon buttons, which are small symbols that provide quick access 
alternatives to using menus or keyboard equivalent keys to perform various functions. To use a 
smart icon button, move the mouse cursor over the icon and click on the button with the left 
mouse button. To view the function of any icon button, place the cursor on the icon and wait 
momentarily, a brief function description will appear near the icon. 
 
View Area 
The View Area is used to view and monitor the captured beam image. The View Area will 
graphically display intensity contour maps (2D), beam centroid coordinates, one or two ROI’s, 
zoom and graphics scroll bars, beam line profiles at any selected view angle. The View Area is 
marked in engineering units (mm) for the entire CCD detecting area. There is a cross hair target, 
which represents the center of the CCD detection area. 
The examined beam Center of Gravity coordinates are also displayed at the main ROI as solid 
cross in blue color, while the ROI limits are marked as dashed lines. 
The size and location of the default ROI can be changed by the user, by graphical means using 
the mouse.  
The beam profiles are being calculated and displayed over the entire area of the CCD, by default. 
There are 4 red colored arrow heads, which mark the beam centroid location. This feature is very 
useful when performing a Zoom operation: in some cases, after a relatively big zoom operation, 
the beam is not viewed on the main view area, and the location and direction of the arrow heads 
will guide the user in locating the beam. 

 
 

 
 
 
 
The digitized pixel intensities of the 
image can be plotted as a 2D contour 
map in one of two different color scales 
shown at the color scale bar (color or 
B/W). When graphics Zoom is enabled 
scroll bars will appear on the sides of the 
View Area.  
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Profile Area 
Just below and to the right hand side of the View Area there is a display of the vertical and 
horizontal beam profiles. There are two types of profiles: sum profiles (which are two orthogonal 
profiles, one along the vertical axis and one along the horizontal axis), or line profiles (which are 
contours of the beam along a line parallel to the vertical axis and a line parallel to the horizontal 
axis.). 

 
 
The profiles are calculated and displayed in conjunction with the main ROI, while other two ROI’s 
can be used for presentation of position measurements only! If Gausian function is On there is a 
presentation of the Gausian beam superimposed over the profile in real-time. 
  
 
 

User Area 
The User Area displays four numerical results. There are two 
types of presentations, according to the system setup setting: 
Beam centroid (X, Y), which is the beam centroid location 
calculated over the entire CCD area. Cross Line coordinates (X, 
Y) displaying either the CCD center of origin (CCD Center option), 
or the cross line coordinates at any point over the CCD View Area 
(Free option), or the beam centroid coordinates or any offset 
value with respect to the centroid (Centroid option) 
ROI 1: the beam centroid (X, Y) in the defined Region of Interest1 
. 
ROI 2: the beam centroid (X, Y) in the defined Region of  
Interest 2. 
 

 In each one of the above listed presentations (Centroid, ROI1 and 
ROI2) a third line can appear, marked as “R” and stands for the 
Radius calculation (squared-root of X²+Y²). This calculation and 
presentation appear when the Radius parameter is set on in the 
System Setup – Position tab. 
 
 
 
 
Profiles Measurement Area 
This area displays the beam width measurement results at the 
3-selected clip levels, for both V Profile and H Profile. 
Also, when the Gaussian function is On, there is a presentation of the ideal Gaussian profile width 
at the same three clip levels selected, and also the correlation factor between the measured 
beam and the ideal Gaussian is displayed. 
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Status Bar 
The status bar is located at the bottom of the µBeam window. It indicates the current status of 
some operational parameters, such as presentation of date and time, Average level and zooming 
level. 

 
 
 
 
6.1 Quick Start 

This chapter provides brief instructions for operating the µBeam system. Full explanations of 
these various operations can be found throughout this manual. 

To begin using the µBeam system: 

1. Connect the µBeam USB device to Hi-Speed USB 2.0 input of the computer. 

2. Connect the 9 Pin RS232 connector cable to the 9-Pin COM Port labeled as  

COM port of the computer (in case you are going to use RS232 

Communication in this session). 

        3. Follow the instructions in section 5.0 Getting Started for alignment of the system. 

To set up a continuous laser beam (default): 

1. Open the Settings menu and select Hardware Setup. 

2. Click the Laser tab and select the CW radio button in the Type field. 

3. Select a shutter speed or gain control that enables an acceptable saturation 
level. 

4. If the image is still saturated at the fastest shutter speed or lowest gain, contact 
factory in order to replace the built-in ND filter inside the system (the µBeam  
contains one NG10 filter that can be installed or removed from the camera).  

To set up a pulsed laser beam: 

1. Open the Settings menu and select Hardware Setup. 

2. Click the Laser tab and select the Pulsed radio button in the Type field. 

3. Select the slowest shutter speed (1/3s). 

4. Set the Trigger Control level to the Left (zero) via Hardware Setup. 
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5. If the image is still saturated at the fastest shutter speed or lowest gain, contact 
factory in order to replace the built-in ND filter inside the system (the µBeam  
contains one NG10 filter that can be installed or removed from the camera. 

To freeze the screen graphics: 

1.   Click  on the Control Toolbar.  

2.   To return to real-time measurement mode, click  on the Control Toolbar.  

 

To print various screens: 

1. To print the entire screen, open the File menu and select Print Screen. 

2. To print the view area only, open the File menu and select Print Frame. 

 

To save screen graphics: 

1. Open the Options menu and select Save BMP File. A sub-menu displays. 

2. Select the screen section to be saved: Frame or Full Screen. The Save BMP 
File window displays. 

3. Enter a filename for the saved screen graphic and click OK. 

 

To view a file: 

1. Click  on the Control Toolbar. The View File window displays. 

2. In the Files of Type field, select the file type for the file you want to view. 

3. Select the file and click OK. 

 

To print a text or bitmap file: 

1. Click  on the Control Toolbar. 

2. Select the file type for the file you want to print Text or BMP. If you select Text, 
the Print Text File window displays. If you select BMP, the Print BMP File window 
displays. 

3. Select the file you want to print and click OK. 

 

To test a laser beam: 

1. Click  on the Control Toolbar. The Analysis Toolbar displays. 

2. Select the parameters to include in the test and set the minimum and maximum 
values for these parameters. 

3. Enter your test related information. 

4. To run the test, click the Test button. The Test window displays the test results. 

5. To save the current test result in a bitmap or test file, click Save in the Test 
window. 
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To measure the distance between two points on the beam image: 

1. From the Control Toolbar, click  to freeze the screen. 

2. From the Control Toolbar, click . The Analysis Toolbar displays. 

3. From the Analysis Toolbar, click .  

4. Select the first point by placing the cursor on the beam image and click the left 
mouse button. Drag the mouse to the second point on the beam image and click 
the left mouse button. A straight line is drawn between these two points and the 
line distance calculation is displayed below the Analysis toolbar. 

 

To measure two beam’s centroids simultaneously: 

1. From the Control Toolbar, click  to select the first Region of Interest. 

2. Move the small rectangle marking  to the first beam presentation on the screen, 
magnify or shrink it to the proper size by graphical means (using the mouse). 

3. From the Control Toolbar, click  to select the second Region of Interest. 

4. Move the small rectangle marking  to the second beam presentation on the 
screen, magnify or shrink it to the proper size by graphical means (using the 
mouse). 

 

To create a data log or Excel file: 

1. From the Control Toolbar, click  to setup the data log. The Log Setup 

window displays. 

2. Enter the information in the Log Setup window. Select between Log and Excel 
file options and click OK. 

3. From the Control Toolbar, click  to start the data log function. 

4. To view the data log file, open the File menu and select View File. Select the 
data log file you want to view and click Open. 

 

To create a Snapshot File: 
The snapshot image is captured as soon as you select the Save Snapshot option. 
You then save the snapshot image as an .SNP file. The snapshot file is saved in 
binary format and can only be processed by this application. 
To create a snapshot file: 

1. Open the Options menu and select Save Snapshot. The Save Snapshot File 
window displays. 

2. Enter a filename for the snapshot file.  

3. Click OK. 

 
To save a Snapshot in TEXT file: 

The snapshot image is captured as soon as you select the Save Snapshot option. You 
then save the snapshot image as a .TXT file. The snapshot file is saved in ASCII 
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format and can only be processed by various programs later on (EXCEL, MATLAB, 
etc.). The file contains 640 columns and 480 rows respectively, with 8-bits intensity 
data for each pixel saved.  
To save a snapshot as text file: 

1. Open the Options menu and select Save Snapshot in Text file. The Save 
Snapshot in Text File window displays. 

2. Enter a filename for the snapshot file.  

3. Click OK. 

 

To view a Snapshot File: 
To view a snapshot file: 

1. Open the View menu and select Snapshot. The Load Snapshot File window 
displays. 

2. Select a snapshot file.  

3. Click Open. The snapshot file displays. 

 

 

To close a Snapshot File: 
To close a Snapshot file, open the View menu and select Snapshot. The system 
restores real-time measurement displays. 

Alternatively, press the X sign at the right top corner of the Windows screen 
application. 

To create a video: 

1. Open the Settings menu and select Video Properties…. The Video Properties 
window displays. 

2. Enter your information and click OK. 

3. Click  on the Control Toolbar. 

To play a video file: 

1. Click  on the Control Toolbar. The Playback Toolbar displays. 

2. Click  on the Playback Toolbar. The Open Video File dialog displays. 

3. From the Open Video File dialog, select the video file you want to view and click 
Open. The video file displays. 

4. Use the Playback Toolbar buttons to play the video. 

5. Click  to close the video file. 

To work with still images: 

1. To capture a still image, click  on the Control Toolbar. 

2. To view a single still image, position the cursor on the still image icon on the 
Status Bar and click the left mouse button. 

3. To close an opened still image click the close button in the upper right corner of 
the image window. If you want to save the still image, click Yes in the Still Image 
window. 
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To transmit serial data over an RS-232 link: 

1. Open the File menu and select Link Setup. The Link Setup window displays. 

2. Click the General tab and enter your information. 

3. Select the Port Settings tab, enter your information and click OK. 

4. Connect the µBeam stand alone unit to another computer using a null-modem 
cable. 

5. Enable the receiving program to receive the file/data. 

6. Open the File menu and select Start Link. If you are transmitting data, the 
µBeam automatically starts sending the data. A link-in-progress message 
displays in the menu bar. 

7. If you are transmitting a file, the Link File window displays. Select the file you 
want to send and click OK. A link-in-progress message displays in the menu bar.  

 

 

 

 

 

 

6.2. RS232 Cable Pin connections 

A null modem cable can be made from a standard RS-232 cable by connecting the pins on one 
end of the cable to the pins on the other end as shown below. 

                                       Null-modem with 25 pins on both sides 

                                       25 Pin Side...                                           25 pin side... 

                                       FG      1                                      1     FG 

                                       TD      2                                          2     TD 

                                       RD      3                                          3     RD 

                                       RTS    4                                         4     RTS 

                                       CTS    5                                         5     CTS 

                                       SG      7                                         7     SG 

                                       DSR    6                                        6     DSR 

                                       DCD    8                                        8    DCD  

                                       DTR   20                                        20    DTR 
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                                       Null-modem with 9 pins on both sides 

                                      9 Pin Side...                                               9 pin side... 

                                      DCD    1                                        1    DCD 

                                      RD       2                                       2    RD 

                                      TD       3                                        3    TD 

                                      DTR     4                                        4    DTR 

                                      SG       5                                        5    SG 

                                      DSR    6                                         6    DSR 

                                      RTS     7                                        7    RTS 

                                      CTS     8                                        8    CTS 

                                      (RI)      9                                      9   Unused (RI) 

 

 

 

 

6.3 Using Attenuating Filters 
The µBeam system is supplied with one calibrated optical filter (type NG10) that can be installed 

inside it to attenuate powerful beams. By doing so, the amount of energy, which the camera is 
sensing is significantly smaller. The use of filters is especially significant when operating a pulsed 
laser beam. 
The NG10 attenuation level is about 240:1 @ 633nm. You can order more filters if desired from 
factory. To attenuate powerful continuous laser beams, select a combination of shorter shutter 
speeds and higher gain levels until the saturation level is acceptable.  

The filter is directly mounted on top of the objective and it is screwed in. 
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6.4 Configuring software 
To configure the software, open the Settings menu and select System Setup. The System Setup 
window displays Settings Tab. 

From the Settings tab, you can configure the following information: 

 Average value of consecutive measurements. 

 Zoom level (change the optical zooming by using the icon. Values from 
X1 to X25, X1.7D and X2D. The digital zoom is applied to the X25 optical zoom. 

 Color or mono display 

 Number of still image bitmap files taken during the Still Image function (for pulsed 
lasers only). 

 

 
6.4.1 Configuring a Continuous Laser Beam 
When using a continuous laser beam, attenuate powerful laser beams by selecting a combination 
of shorter shutter speeds and or higher gain levels, until the saturation level is acceptable. Refer 
to Gain issues for more information. 

To configure a continuous laser beam: 

1. Open the Settings menu and select Hardware Setup. 

2. Click the Laser tab and select the CW radio button in the Type field. 

3. From the Control Toolbar, select a shutter speed using the drop down list in the 

shutter field  that enables an acceptable saturation level. 

4. If the image is still saturated at the fastest shutter speed, try setting the gain level for 
a higher level. If still observing saturation – contact factory in order to get additional  
ND filters for the µBeam  system to obtain an acceptable saturation level. 

 
 

6.4.2 Configuring a Pulsed Laser Beam 
To configure a pulsed laser beam: 

1. Open the Settings menu and select Hardware Setup. 

2. Click the Laser tab and select the Pulsed radio button in the Type field. 

3. From the Control Toolbar, select the slowest shutter speed (1/3s) using the drop 

down list in the shutter field . 

4. From the Control Toolbar, select the gain level using the drop down list in the gain 
field. 

5. From the Hardware Setup, Laser tab, set the Trigger control level at the minimum 
value (to the left side of the scale). Increase the trigger level manually by sliding the 
bar graphically. The trigger control is also displayed at the Control Toolbar area. 

6. If still observing saturation – contact factory to order other/additional ND filters to the  

     µBeam camera to obtain an acceptable saturation level. 
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7.0 Installation 
This chapter provides instructions for installing the hardware and software for the µBeam USB 
2.0 system.  
 

7.1 Hardware Requirements 
To run the µBeam USB 2.0 version, the computer system must meet the following minimum 
requirements: 

Item Minimum Requirements Recommended Requirements 

CPU Pentium 4, 1 GHz Pentium 4, 1.7 GHz 

System RAM 128MB RAM  

Hard disk 100MB HD free  

CD ROM drive Any type  

Operating system Windows XP/7/8/10  

Mouse Microsoft mouse or equivalent  

VGA display 1024 x 768 resolution  

VGA card 16MB 16 bit color 64MB 16 bit color 

USB Port One free High Speed USB 2.0  

 
 

 

7.2 Software Installation - µBeam USB Device 

Important Note:  Please install the USB device driver before connecting the 
USB Device to your computer! 

 

1.Perform Software Installation. Only after you click “Finish” to complete the software 
installation procedure, continue with the Hardware Installation as follows: 

2.Connect the power supply cable to the µBeam USB device via the 12V jack and plug 
the power supply into the surge-protector outlet. 

3.Plug the µBeam USB Device into a Hi-Speed USB 2.0 -compliant port.  

4.The USB will be detected and the New Hardware Wizard will launch. 

 

Important Note:  Please do not connect / disconnect  µBeam USB device, 
while application program is running! 

 
 
1.  A Welcome screen appears when beginning the software installation routine. Click Next. 
2.  Insert your User Name, Company Name and System S/N (appearing on the system 
CD). 
3.  The following screen is a Registration Confirmation. Click Yes in order to confirm. If you 

click No, the software will return back to a previous prompt (stage 6 above). 
Now provide the full path for installation of the µBeam USB 2013 system software: 
More information about the exact folder for the software and branching in existing folder 
for µBeam USB 2013 system software can be done in the Select Program Folder 
prompt. 
Click the Next button to proceed. 
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4.  Copying files routine. Click Next button. At this stage the system copies all files from the   
CD-ROM to the selected directory in your computer. There is a graphical presentation 
showing the amount of data copied to the system disk. If the Cancel button is pressed 
the installation is aborted. 

5.  For Windows 7: 
 
 

  
  Windows Update 
 

  
  Download and Install Updates 
 
 
 Press “I Accept” button for install update. 
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    Update installation status 
 

 
 

  
 
  Installation complete 
 

6.  Setup complete. At this stage, the user is requested to Restart the computer (Reset). 
Select Yes to Restart. The reason for the Restart operation is: during the installation 
process, there were a few drivers added to the Windows Registry, these drivers are 
required for the system proper operation. The drivers are activated only after the 
computer is rebooted. 
If you select No at this point, you will have to perform the Restart operation manually 
later on. 
Should you face any problem with the video device installation in your computer – 
please refer to the section: Troubleshooting for more information. 
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7.3 Hardware Installation – µBeam USB Device 
Plug the µBeam USB device into a Hi-Speed USB 2.0 port. 

The USB device will be detected and the New Hardware Wizard will launch. 

 

7.3.1 Windows XP 

7.3.1.1. Installation Video Capture 

1. The following message is displayed 

 

     Found new hardware message 

 

 

 

 

 
New Hardware ready to use 

 
 
 

7.3.1.2. Installation USB Serial Port 

 

    Found new hardware message 
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  Welcome Screen. Press “Next” to continue. 

 

  New Hardware Wizard. Press “Next” to continue. 

 

Digital Signature Message. Press “Continue Anyway". 
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Installing… 

 

Complete installations Video Capture 

 Press Finish now and continue with the video capture installation. 

 
New Hardware ready to use 
 

After completion of USB device installation, when the device is configured successfully, 
the blue led on the front panel of the MicroBeam Head should be blinked.  

Additionally one can check the installation status under System Properties, Device 
Manager Tab and verify that “USB 2860 Device” line is listed under the Sound, video 
and game controllers devices, and “DO USB Serial Port” line is listed under the Ports 
devices. 
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Drivers installed list  

 
 
 
 
 
 
 
 
 
7.3.2 Windows 7/8/10 
 

The following message is displayed 

 
Installing device driver software 
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Devices are ready to use 
 

After completion of USB device installation, when the device is configured successfully, 
the blue led on the front panel of the MicroBeam Head should be blinked.  

Additionally one can check the installation status under System Properties, Device 
Manager Tab and verify that “USB 2860 Device” line is listed under the Sound, video 
and game controllers devices, and “DO USB Serial Port” line is listed under the Ports 
devices. 

 

 

Drivers installed list 
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7.4 Running the Software     
Make sure hardware is installed properly. (See Hardware Installation – µBeam USB 2.0 
Device). Boot the computer. 

From the Start Menu, select Programs, then choose MicroBeam USB 2017 folder, and then 
click on the MicroBeam USB 2017 program. Alternatively, you can activate the software by 

placing the mouse cursor at the MicroBeam USB 2017 Icon  and click the mouse button 

twice. 
To end a program session, open the File menu and select Exit. 
The MicroBeam USB saves all current setup parameters when you exit a session. 

 
Possible Errors that indicate an interface board conflict: 
There are a few common symptoms, which point to an interface board conflict: 
* System Lock-up during software startup. 
* There is no picture displayed on the screen 
* Displayed measurements are sporadic and erroneous. 

If your symptoms match one of those presented above, or if the µBeam System was 
working at one time and has now stopped working, check for conflicts with other plug in 
cards in the same computer. 

 
If it has no affect and no new software of any kind has been installed since the µBeam System 
last worked and the computer has not been moved, contact Duma Optronics Inc. for immediate 
support. 
More information about Installation problems in the Troubleshooting section. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Beam User Manual  29  

8.0 System Overview  
This section provides a general overview of the system Main Menu items of the µBeam System. 

The following command menus are available on the Main Menu: 
 

                                        
To display menu commands and close selected menus, use one of the following methods: 
 
Display Menu Commands 
Move the cursor to the desired menu item on the Menu Bar with the mouse or arrow keys and 
click the left-hand button of the mouse or press the Enter key. 
OR Hold down the ALT key and press the underlined letter (hot key) in the menu name. 
 
Close Menu 
Click the left-hand button of the mouse on the menu name again or on another menu item OR 
Press the ESC key. 
 

File Menu                
The File menu allows the user to perform many file operations such as: save, view, print, delete 
or transmit data files. It can be used to also save data in real time into Excel software for further 
analysis at a later stage. 
 

View Menu 
The View menu enables the user to view additional ROI’s (Regions of Interest), select type of 
profile, as well as activate/deactivate the control toolbar and the status bar.  

 
Options Menu 
The Options menu enables saving and recording operations: 
 Save video, save a still image, save a BMP file, save snapshot. 
 Insert user data. 

  
Settings Menu 
The Settings menu enables the user to perform System setup parameter settings, including: 
system settings, hardware settings, video properties, and offset. 

 
Help Menu 
The Help menu provides on-line help on all system functions and buttons. The help screens are 
intended to provide short explanations about the current function and guidelines for operation. 
One can select the part of Help, which is required, either the Contents Window, the Search 
Window, or information on the current Active Window. 
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9.0 Operating Instructions  
 
This section provides complete and detailed overview of the system software. It describes the 
layout of each operating screen as well as its setup screen. 
 

 
 
9.1 File Menu 
The File menu allows the user to perform many file operations. 
File operations include: View, Delete, Print, Save and Transmit data files.  
Upon activation of File function, the following list of options appears: 

 

   

Note that the list of keys or key combinations on the right side of the menu indicate the keyboard 
shortcut for that feature. These shortcuts may be activated from the Main Window by pressing the 
keyboard combination. 
If a menu item is gray it means that item is unavailable until something else is done. For 
example, to start Log there is a need to go through Log Setup first. 
For more information on each option - place mouse cursor at the option name and click its LEFT 
button. 
 
View File... 
Print... 
Print Frame 
Print Screen 
Print Setup 
Start/Stop Log 
Log Setup 
Start/Stop Link 
Link Setup 
Exit 
 

9.1.1   View File...     Ctrl+V 
View File provides the user the ability to view any stored file, including data log, 
configuration file, Test file, bitmap and video files.  

View File can be selected from the File menu, the keyboard shortcut Ctrl+V, or via the Control 
ToolBar. 
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To view a file: 

1. Select View File from the File menu. 
2. Select the "File Type" for the file to be viewed. 

 -Log files have the extension: *.LOG 
 -Config files have the extension: *.INI 
      -Test files have the extension: *.TST 
       -Image files have the extension: *.BMP or *.JPG 
       -Video files have extension:              *.AVI 
       -Excel files have extension:              *.XLS 
 
3. There should be no need to change the directory because most files should be stored in the 
system directory (the default) 

4. Click on a file from the file list on the left. 

5. Click OK. The file can now be displayed in the notepad application. 

 


 


9.1.2   Print... 
Print allows the user to print an entire saved data file. 
 
Print can be selected from the File menu, or via the Control ToolBar. 
The data is printed in the same format as it is shown on-screen, via View Data File. 
Once Print is activated, a sub-menu is opened, as follows: 

Text file  (or the keyboard shortcut Ctrl+T). 

Image file  (or the keyboard shortcut Ctrl+I). 
 
Print a Text file: 
1. Select Text file via option Print in File menu. 
2. Select the File Type for the file to be printed: 
 - Log files              (*.LOG) 
 - Config files (*.INI) 
 - Test files              (*.TST) 
 - Excel files  (*.XLS) 
3. There should be no need to change the directory because most files should be stored in the 
system directory (the default). 
4. Click on a file from the file list on the left. 
5. Click OK. 
 
Print an Image file: 
1. Select Image file via option Print in File menu. 
2. Select BMP files or JPG files. 
3.   A list of all saved BMP/JPG files (having extension of *.BMP or *.JPG accordingly) is 
displayed. 
4.   There should be no need to change the directory because most files should be stored in the 
system directory (the default). 
5. Click on a file from the file list on the left. 
6. Click OK. 
A message box "Printing..." is displayed as long as the program sends the file to the printer via 
the Windows Print Manager. 

To select and setup a specific printer for printing select Print Setup from the File menu prior to 
selecting Print - use Print Setup. 
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9.1.3 Print Frame       F2 
Print Frame enables an immediate printing of the image screen as seen at the View Area. 
  
Print Frame can be selected from the File menu, or the keyboard shortcut F2. 
A message box "Printing..." is displayed as long as the window graphics is being transferred from 
the program to the printer via the Windows Print Manager. 
 
To select and setup a specific printer for printing select Print Setup from the File menu prior to 
selecting Print Frame. Activate Print Setup. 
 






9.1.4 Print Screen       F3 
Print Screen enables an immediate printing of the full screen display. 
 
Print Screen can be selected from the File menu, or the keyboard shortcut F3. 
A message box "Printing..." is displayed as long as the screen graphics is being transferred from 
the program to the printer via the Windows Print Manager. 
 
To select and setup a specific printer for printing select Print Setup from the File menu prior to 
selecting Print Window. Activate Print Setup. 
 
 
 

9.1.5 Print Setup 
Print Setup enables the user to load the appropriate printer driver, set the orientation and 
paper size, via the standard Windows Pop-Up Setup Screen.  

Print Setup is selected from File menu. 

Make sure the appropriate printer driver is selected prior to activating Print..., Print Frame or 
Print Screen functions. 









9.1.6 Start/Stop Log 
 

 Start Log. 
Start/Stop Log is selected from the File menu, or from the keyboard shortcut Ctrl+L, or from the 
Control ToolBar. Activate this option in order to initiate a data logging operation, or to terminate 
current data logging session. The duration of the experiment, the rate of data logging along with 
the filename should be set prior to activating this option through the Setup Log option. 

While log is in progress, a banner is displayed at the top right corner of the Control Toolbar. 

 Start Log button is disabled until the following parameters are configured in the Setup Log 
option: 

  - The duration of the experiment, 
  - The rate of data logging, 

 - The Log filename, 
  - Log file type: Excel or Log. 
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  During Log, the Start Log menu item and Control ToolBar icon will change to Stop Log. 

 
Once saved, the data can be viewed on screen through View File.., printed for reference through 
Print..., or transmitted via an RS232 interface through Link. 
If Excel file type was selected, data will be saved in real-time to a file type XLS via Excel. 

Once saving data via Excel is activated, the banner Excel in progress appears at the right area 

of the Control Toolbar. 

After the saving to Excel operation is terminated various presentations and analysis functions can 
be performed. 

 

 Stop Log 

Stop Log is selected from File menu, or the Control Toolbar. The Log will save data according 

to the parameters set through the Log Setup.  
The Log operation will automatically terminate after the user-preset time period in duration. 
However, activating option Stop Log in order to stop the saving operation at any prior stage can 
also terminate the session. 
 
Note:  When LOG file type was selected, all data collected will be saved in a file name *.LOG, 
which is a text file and can be imported into other programs. 
When Excel file type was selected, all data collected will be saved in a file name *.XLS. 
 
LOG file is stored in a text ASCII format so they can be easily printed, viewed, and analyzed by 
other programs.  
  

-     System name and software version 
-     User data (if inserted by the user) 
-     Date and Time 
- Serial number 
- Screen size 
-     Average level in use 
- Zoom level in use 
- 3 Clip levels in use for both V and H profiles 
- Line Profile angle with respect to the origin 
- Gain level 
- Shutter level 
 
Additionally, for each measurement taken, the following data is saved: Time, Centroid 
displacement value in µm: X value, Y value (centroid position of main Region of Interest area 
ROI(1)), and a set of Horizontal (H) and Vertical (V) profiles widths at 3 different clip levels which 
were preset by the user. 
 
At the end of each Log file, there is a statistics summary, including: Minimum value, Maximum 
value, Mean value and Standard deviation value for each parameter saved. 
 
Following please find the Log file example: 
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              *** MicroBeam USB 2.0 Measurement system, Version 2.0 *** 

 

UserData:       

 

Date:  01 October 2017 

Time:  08:54:24 

 

Serial number: 001 

 

Size:           720x576 

Average:        Off 

ClipLevel I  :  13.5% 

ClipLevel II :  50.0% 

ClipLevel III:  80.0% 

ProfAngle:      -15° 

 

Zoom:           Off 

Gain:           17 Db 

Shutter:        1/2000 sec 

 
Time CentroidX  CentroidY  H_WidthI  H_WidthII H_WidthIII V_WidthI V_Width II V_WidthIII 
(sec)  (µm)      (µm)       (µm)       (µm)       (µm)      (µm)      (µm)       (µm) 

 

 
0.00  -4.070    -3.576     9.795      5.731     3.324     11.391    6.601       3.859          

0.35  -4.070    -3.594     9.867      5.834     3.324     11.478    6.720       3.859          

0.70  -4.070    -3.576     9.795      5.731     3.324     11.391    6.601       3.859          

1.06  -4.070    -3.594     9.867      5.834     3.324     11.478    6.720       3.859          

1.45  -4.070    -3.576     9.795      5.731     3.324     11.391    6.601       3.859          

1.80  -4.070    -3.594     9.867      5.834     3.324     11.478    6.720       3.859          

2.14  -4.070    -3.576     9.795      5.731     3.324     11.391    6.601       3.859          

2.49  -4.070    -3.594     9.867      5.834     3.324     11.478    6.720       3.859          

2.84  -4.070    -3.576     9.795      5.731     3.324     11.391    6.601       3.859          

3.18  -4.070    -3.594     9.867      5.834     3.324     11.478    6.720       3.859          

 

*************************  Statistics  ***************************** 
Min   -4.070    -3.594     9.795      5.731     3.324     11.391    6.601       3.859          

Max   -4.070    -3.576     9.867      5.834     3.324     11.478    6.720       3.859          

Aver  -4.070    -3.585     9.831      5.782     3.324     11.435    6.661       3.859          

STD    0.002     0.009     0.038      0.054     0.000      0.046    0.063       0.002          

  
 
 
 
 

9.1.7    Log Setup 
 
This setup screen allows the user to customize the Log operation to suit a particular need: 
the duration of an experiment, the rate of data saving into file, and the Log filename can be 
input by this setup screen. Also, data can be saved either to a Log file or to Excel file for 
further analysis at a later stage. 
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Log Setup is selected from File menu, or from the 
Control ToolBar. 

 
Upon selecting this function and pressing OK button, 
one can initiate the log file operation via Start Log 
option, in File function. Press Cancel button to 
abandon Log Setup parameters. 

   

 

 

 

General tab settings include: 

Logtype:                     LOG file or Excel file 

File Name -  Providing the system with a filename where Log data will be saved to. 
Activate Button Browse... in order to provide the system with a 
filename via the standard Windows File Input interface box. 

 
Note:  When LOG file type was selected, all data collected will be saved in a file name *.LOG, 
which is a text file and can be imported into other programs. 
When Excel file type was selected, all data collected will be saved in a file name *.XLS. 

 
At the end of each Log file there is a statistics summary, including: Minimum value, Maximum 
value, Mean value and Standard deviation value for each parameter saved. 
 
 
Settings tab parameters include: 

 

Interval Insert the time interval between consecutive 
measurements. The interval can be set in: hours (h 
button), minutes (m button), or seconds (s button). 
After selecting h, m, or s parameters, enter the 
required value for each parameter using the data 
entry box.   

Duration Insert the length of time during which the 
system is to acquire data. The Log operation ends 
automatically at the end of the period. The logging 
data operation can be stopped prematurely using the 
Stop Log function. The duration for the measurement 
can be set in: hours (h button), minutes (m button), or 
seconds (s button). After selecting h, m, or s, enter the 

required value in the data entry box. 

Logtype - Provide the system with a method to control the data logging operation: 

Time:   Save measurements for a pre-defined duration, the interval between the saved 

measurements is also defined prior to saving. 

Points: Save a certain amount of measurements taken at the system’s data capturing 
rate, the exact figure is entered at the points field to the right of this option. 

Manual: Save a certain measurement to the file by pressing the SpaceBar. This method 
is called “Event oriented”, meaning once the user observes a certain 
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measurement on the screen he can control the system to save this exact 
measurement data to the file, rather than other methods of stream data saving. 

 
Activate Button Help to get help on this window. 
Press OK button to confirm, or Cancel button to abandon. 








9.1.8 Start/Stop Link 
Start/Stop Link provides the capability to operate an RS232 Communication channel for 
serial data transmission. 

Start/Stop Link is selected from the File menu, or the keyboard shortcut Ctrl+K. Any displayed 
data or pre-saved Log file can be transmitted via Link. Typically, this feature is used to transfer 
real time data from the system to another computer over a serial cable. The other computer can 
receive the data using a program that can communicate over a COM Port like Windows Hyper 
Terminal program. 

While link is in progress, a banner is displayed on the top right corner of the Control Toolbar. 

   
 
To Transmit data/file over RS232: 

1. Connect the system to another computer using a null-modem cable. 

2. Before using Start Link, the Link parameters in Link Setup must be configured to match the 
communications protocol of the computer that will receive the file/data. 

3. Enable the receiving program to receive the file/data. 

4. Select Start Link from the File menu.  
 
In case you are transmitting data, after Start Link is pressed the program immediately starts 
sending measured data via RS232. 

The data transmitted includes the following information:  

Time of measurement: Time, Beam Centroid (X), Beam Centorid (Y), ROI1 (X), ROI1(Y), 
ROI2(X), ROI2(Y), CLIP_LEVEL1, CLIP_LEVEL2, CLIP_LEVEL3,  H_WidthI,  H_WidthII, 
H_WidthIII, V_WidthI, V_Width II, V_WidthIII. 

 

In case you are transmitting a file, a standard Windows File box is displayed. 

  - Select the File Type for the file to be sent: 
       - Log files  (*.LOG) 
       - Config files (*.INI) 

 - Test  files (*.TST) 
 - Excel file (*.XLS) 

6. Click on a file from the list on the left. 

7. Click OK.   
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The file (or measured data) is transmitted in the background while the system continues to 
capture data. A link status window will be displayed at the upper left-hand corner of the Window 
area. When finished the Linking status message will disappear. 

To stop a Link in progress, when Link is transmitting on-line data select Stop Link from the File 

menu.  
Link is terminated automatically upon completion of the transmission of a file, or can be stopped 
by selecting Stop Link from File menu. 
 
 
 
 

9.1.9 Link Setup 
Link Setup allows the user to configure the system to suit a particular set of parameters 
needed for the RS232 transmission.  
Link Setup is selected from File menu. 
 
The parameters relating to the RS232 serial link are grouped in two tabs: General and Port 
Setting tabs. Click on the required tab. 

 
   

General  
This option can be activated from Link Setup window and 
includes the following two parameters setting: 
 
Port: Selects the computer communication port, through which 
data is to be transmitted over the RS232 link. Ensure that the 
selected port does not coincide with the port being used for the 
mouse. Many PC's have the mouse installed on COM1. 
The possible values for Port are 1 through 4, for COM1 through 
COM4 respectively, and can be entered in the data entry box. 
 
Transmit: Transmits a File (a pre-saved text file), or Data (real-

time measurements). Selection is made using the Option Buttons (File or Data). If File is 
selected, the system opens a File Selection Dialog box in order to provide the text file name & 
path information. 
If Data is selected, the system will transmit on-line live data. The system will send the data in the 
sequence and format of the saved data in the LOG file. 
  
Activate Help button to get help on this window. 
Press OK button to confirm, or Cancel button to abandon. 
 
 
 

Port Settings  
This option can be activated from Link Setup window. 
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Port Settings Tab includes the following four parameters 
related to the RS232 transmission: 
 
Bits per second: Selects the right transmission rate for 
the RS232 link. The possible values, are: 110, 300, 600, 
1200, 2400, 4800, 9600, 19200, 38400, 57600, 115200. 
This setting must match the same setting on the receiving 
computer, and can be entered by clicking on the down 
arrow and selecting the value from the list. 
 
Parity Bit: Determines whether or not a parity bit is to 
be transmitted. The possible values are: None, Odd, 
Even, Space, Mark. This setting must match the same 
setting on the receiving computer, and can be entered by 
clicking on the down arrow and selecting the value from 
the list. 

 
Data Bit: Determines the number of bits in use for the RS232 transmission. The possible values 
are: 4, 5, 6, 7, and 8. This setting must match the same setting on the receiving computer, and 
can be entered by clicking on the down arrow and selecting the value from the list. 
Stop Bit: Determines the number of stop bits to be transmitted. The possible values are: 1 or 2. 
This setting must match the same setting on the receiving computer, and can be entered by 
clicking on the down arrow and selecting the value from the list. 
 
Activate Button Help to get help on this window. Press OK button to confirm, or Cancel button to 
abandon. 
 
 
 

9.1.10 Exit 
Use Exit to terminate the current session (close the application program and exit 
Windows). 

 
Exit is selected from the File menu. 
All current setup parameters will be saved automatically when program is exited in the uBeam.INI 
file and will be reloaded when the program is started. 
 
 
 
 
 
 

9.2 View menu 

 
View enables the user to control the screen presentation as follows: 
Add/Remove ROI’s, select the Profiles type, activate/deactivate the presentation bars 
(Toolbars, Status Bar). 
 
The following commands and menu items are available: 
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Available functional windows, are: 

Projection 

Profiles 

Position Data 

Snapshot 

Toolbars 

Status Bar 
 
 
 
 

9.2.1 Projection 
Select any one of the following options for the Projection presentation at the major ROI: 

 
 
To select the graphical presentation: 

From the Control Toolbar, click  for a 2D display or  for a 3D display. Or, 

Open the View menu and select Projection  2D or 3D. 

 
 
 
 
 
9.2.2 Profiles 
Select any one of the following options for the Profiles presentation at the major ROI: 

 
 
Sum Profiles: Displays the two orthogonal profiles, one along the vertical axis and one along  
the horizontal axis. Each profile is composed of a summation of rows and columns at a beam 
cross section. 
 
Line Profile: Displays the contour of the beam along a line parallel to the vertical axis and a line 
parallel to the horizontal axis. The two lines, along which these contours are displayed, are 
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designated as a cross hair cursor. The cross hair cursor can be moved across the CCD entire 
area, so the displayed profile is the cross section line profile located by the cursor. 
 
Note: The line Profile can be defined according to the Cross Line options (see 9.2.3). 
 
 

 
9.2.3 Cross Line 
Cross Line function toggles between two possible settings for the X-Y scale coordinates 
presentation, as follows: 
 
- Free: Displays a cross hair target at a user’ selected coordinates. Define any point over the 

CCD View Area to be the cross line coordinates, by moving the mouse to the selected point 
and clicking the mouse right-hand button once. Yellow lines mark the cross line coordinates, 
and the coordinates values are displayed at the cross line field in the User Area. 

 
- Centroid: Displays a cross hair target which represents the system’ main ROI centroid 

coordinates. Blue lines mark the centroid coordinates, and the centroid values are displayed 
at the User Area section. 

 
Note:  When Centroid is selected, one can define a relative point over the View Area which is 
referred to the centroid by a certain “offset”. 
In order to set the centroid offset move the mouse to the selected point and click the mouse 
right-hand button once. The centroid offset coordinates will be displayed at the User Area. 
Return to centroid display (no offset) by double clicking on the mouse LEFT-hand button. 
This operation also sets the main ROI to its default setting (in case it has been changed in 
size and location) 

 
 
 
 
 

9.2.4 Position Data 
Position Data enables toggling between Absolute position reading (the default) and the relative 
position reading. 
When Relative is selected then all the position centroid data will be calculated versus the Cross 
Line center, and a small message which reads “Relative” will be displayed at the top left corner of 
the View Area. 

 
The Relative point coordinates can be set by graphical means, by dragging the Cross Line center 
to any requested location over the View Area. 

 

 
The software calculates the centroid of the beam which resides inside the ROI area only, 
disregarding the energy outside of this region. Thus, the result of the beam centroid calculation 
will be displayed in the appropriate ROI area at the User Area.  
 

Note: 
- The Profiles presentation are displayed over the entire area of the CCD. If additional ROI’s 

are selected and opened (ROI1 / ROI2) these will obtain beam position centroid information 
only, not Beam Profile information. 

  
The user can change the default size and location of the ROI by graphical means: 
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- Change the ROI location: by placing the mouse cursor inside the ROI frame and dragging 
the ROI frame to any required location while pressing the mouse left button. 

- Change the ROI size: by placing the mouse cursor at one of the ROI frame edges and 
dragging it slowly to the required size while pressing the mouse left button. 

- Restore ROI size and location (default): by pressing first the mouse left button and then 
pressing the mouse right button. The ROI is brought back to its original size and location over 
the CCD area. 

  
 
 
 
 
 

9.2.5 Snapshot 
Snapshot enables viewing a saved snapshot file, or closing a snapshot file and returning to a real 
time measurement mode. 
To view a Snapshot File: 

- Select Snapshot option. The Load Snapshot File window displays. 

- Select a snapshot file.  

- Click Open. The snapshot file displays. 

To close a Snapshot File: 
- Select Snapshot option. The system restores real-time measurement displays. 

Alternatively, press the X sign at the right top corner of the Windows screen application.  

 
 
 
9.2.6 Toolbars 
 
Toolbars can be selected from the View menu,  
 

  
Analysis Toolbar 

Control Toolbar 

Playback Toolbar 
 
 
 
 
 

9.2.6.1   Analysis 
 
Analysis is selected from the Control Toolbar or from Toolbars option in View menu.  
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Ellipse - Defining a laser beam frequently requires a definition of beam elliptical foot-print and 
beam orientation with respect to the camera axis. A special function which calculates the best fit 
ellipsoid to the examined beam is provided by the Ellipse function. 
 

 
 

Line - Performs accurate distance measurements between any two points on the beam 
topographic map. The two points are selected using the mouse and the calculation result 
(distance between these points) is displayed at the Analysis Toolbar window just below the tool 
buttons of the Analysis Toolbar. 
 

   
The µBeam can accurately measure distances between any two points on the beam image. You 
select the end points and the µBeam calculates and displays the results.  
To measure the distance between two points on the beam image: 

1. Open the Options menu and select Freeze Mode, or from the Control Toolbar, click 

. 

2. Open the View menu and select Toolbars at Analysis, or from the Control Toolbar, 

click . The Analysis Toolbar displays. 

3. From the Analysis Toolbar, click .  

4. Select the first point by placing the cursor on the beam image and click the left mouse 
button. 

 

5. Drag the mouse to the second point on the beam image and click the left mouse 
button. A straight line is drawn between these two points and the line distance 
calculation is displayed below the Analysis toolbar (see attached figure). 

 

Test – Activates a test routine, which allows the user to test the laser beam, based on the user 
pre-defined pass/fail criteria.  The test results are calculated while being in Freeze Mode for any 
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one of the following user-selected parameters: 

 Centroid X Horizontal (µm) 

 Centroid Y Vertical (µm) 

 ROI1 Centroid X Horizontal (µm) 

 ROI1 Centroid Y Vertical (µm) 

 ROI2 Centroid X Horizontal (µm) 

 ROI2 Centroid Y Vertical (µm) 

 Width X Horizontal (µm) 

 Width Y Vertical (µm) 

 Gausian X Horizontal 

 Gausian Y Vertical 

 Correlation X 

 Correlation Y 

 

       Parameters that are not activated in the test setup are marked as “Skipped” in the Test  
       window. To test a laser beam: 

1. Open the View menu and select Toolbars then Analysis, or from the Control 

Toolbar, click . The Analysis Toolbar displays. To run the test, click  on the 

Analysis Toolbar. The Test window displays. 

2.  Select the parameters to include in the test and set the minimum and maximum   

      values for these parameters. 

3. Enter your test related information (Test Name and/or Test Data). 

 
4. Press the Test button to perform a Test operation. 

The test window displays the beam’s test results based on the parameters entered in 
the Setup parameters.  
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To save the current test results in a bitmap or test file, click Save. To print the current test results, 
click Print. 

To stop the test and close the test window, close the Test window or click  on the Analysis 

Toolbar. 
 
 
 

Coma - The coma function provides a novel measuring technique of the optical performance of 

objective lenses for optical disk systems. 
The coma aberration has a magnitude and direction. The magnitude and the direction of lens 
decentering correspond to the magnitude and direction of the coma. The radii of the first dark ring 
R1 and the second dark ring R2 are given by the following: 

  R1 = 0.61  / NA 

  R2 = 1.12  / NA 
Under the assumption that there is no aberration and that the intensity distribution of the incident 

light is uniform. Thus  is the wavelength, and NA is the numerical aperture of the lens. The 
feature of coma aberration is characterized well by the profile between the first and second dark 
rings. 

 
 
The graph presentation shows the intensity distribution between the first dark ring and the second 
dark ring and their coma vectors. 
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9.2.7 Control Toolbar 
 
Select Control ToolBar from the View menu, in order to show/hide the ToolBar 
respectively. 
 
Control ToolBar is a collection of shortcut buttons to menu items that are used frequently. Each 
shortcut is represented by a special icon (picture) and is called a Tool Button. 

To activate a tool button, place the mouse over the button and click the LEFT mouse 

button. The button will change both color and shadow to designate the fact that this 
function is activated. 

 
This is an example of ToolBar (for CW lasers):  
 

 
 
This is an example of ToolBar (for Pulsed lasers):  
 

 
 
To view the function of each icon button, place the mouse cursor on the icon and wait 
momentarily, a brief function description will appear near the icon. 
 
 
 
 

9.2.8   Playback Toolbar 
 
Select Playback ToolBar from the Toolbars in View menu, in order to show/hide the 
ToolBar respectively. 
During a video playback routine, the µBeam displays a digital presentation of the time elapsed 
since the video began, as well as the number of the frame being displayed. 
To play a video, open the video file you want to see and use the following buttons on the 
Playback Toolbar to play your video: 

 
Play Plays the recorded video file. 

 
Stop Stops the playback of the video file once it is started. 

 
Rewind Rewinds the current video one frame backwards. 

 
Forward Fast forwards the current video one frame. 

 
Open Opens a video file. 

 
Close Closes an open video file. 

There is a slide bar in the middle of the Playback Toolbar, which moves in accordance 
with the video’s progress. It is also possible to use this slide bar to rewind the video to its 
starting point, or to bring it to the end of the video. 

 

 
To play a video file: 
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1. Open the View menu and select Toolbars then Playback.  

OR 

Click  from the Control Toolbar. 

The Playback Toolbar displays. 

2. Click  on the Playback Toolbar. The Open Video File dialog displays. 

3. From the Open Video File dialog, select the video file you want to view.  

4. Click Open. The video file displays. 

5. Use the Playback Toolbar buttons as defined above to play the video. 

6. Click  to close the video file. 

 

 

 

9.2.9 Status Bar 
 
Select Status Bar from the View menu, in order to show/hide Status Bar respectively. 

 
The Status Bar provides the status of various settings and operational conditions. 
If the system is not operating as intended, the Status Bar provides a quick summary of why it is 
not functioning properly. The Status Bar is a valuable aid in diagnosing unexpected results, and 
can quickly help you get back to the desired operation. 
Example of Status Bar: 
 
 

 
 

 The Status Bar also provides quick access to System or Hardware setup parameters. 
One click at the panel opens the System/Hardware setup window. 

 
Status Bar Panels: 

Date and Time 

Average - number of data samples that are being averaged before calculations and display of 
the data is performed. 

Scale – The zooming level used in microns/division 

Profiles type – Indication of profile type 

Still Image 
 
 
 

 Region of Interest 
 
The ROI function selects a region of interest within the total CCD detector area.  
 
To activate the ROI press the appropriate ROI button on the ToolBar. The ROI region is defined 
by a square, the color of which is identical to the numerical presentation at the User Area, as well 
as to the ROI tool button color. The user can control the size of the ROI and its location by 
graphical means using the mouse. 
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The software calculates the centroid of the beam, which resides inside the ROI area only, 
disregarding the energy outside of this region. Thus, the result of the beam centroid calculation 
will be displayed in the appropriate ROI area at the User Area. In case the Radius parameter is 
set On at the Position Setup – Position tab, then there is an additional calculation and display of 
the R value, which is the radius of beam centroid with regards to the cross line. 
 
Note: The default ROI is the total centroid of the energy impending on the entire CCD area. 
 
The user can change this default by graphical means, by dragging the ROI frame to the location 
and size at the screen, which is of interest.  
The default setting of the system when it boots up is the entire CCD area is being considered the 
area main region of interest and the beam centroid calculation is performed over the entire CCD 
area. This default can also be changed by graphical means, the same way both other ROI’s 
borders and location can be set. 
In order to resume the default setting, double click on the mouse Left button. 
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9.3 Options Menu 
 
Options menu enables the user to record Video/Still Image files, save a BMP file and input 
User Data. It also enables freezing a screen display and selection of the zooming criteria 
(axes / centorid stabilize).  
The following commands and menu items are available from this menu: 

 

Available options for Options menu are: 
Record Video... 
Still Image 
Tile Image 
Close All Images 
Save Image file ... 
Save Snapshot 
Save data in Text file ... 
Freeze Mode 
User Data 
A check mark in front of a menu item means that the function is enabled. 
 
 
 
 

9.3.1   Record Video... 
 
Record Video enables recording and saving movies (or a continous set of images). The movies 
will have the file extension .AVI. 
 
To initialize the video parameters: 

Open the Settings menu and select Video Properties….window. 

 
To record a Video: 
When you record a video, the video is saved in the file you specified in the Video Properties 
window. If you don’t want to overwrite this file, you need to change the file name before recording 
a new video. 
During video recording, a moving bar on the Status Bar (just to the right of Zoom field) graphically 
displays the progress of the recording operation. 
 

Open the Options menu and select Record Video. A checkmark is placed beside this option. Or 

Click  from the Control Toolbar. 
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When the µBeam is recording a video, a message displays on the top left side of the screen, 
which reads: 

 

 

Stopping the Video Recording: 
The video recording automatically terminates after the user-preset time is reached. However, you 
can stop recording at any time. When recording terminates, it is automatically saved in the file 
you specified during video setup. 
To stop the video recording: 

Open the Options menu and select Record Video. The checkmark is removed from this 

option, or Click  from the Control Toolbar. 

 

 

 

9.3.2   Still Image 
This section describes how to capture high quality digital images with your µBeam system. A still 
image is captured by digitizing a single video frame. The still images can be saved as bitmaps. 
The captured image is displayed as an icon on the Status Bar with a number assigned to it. If you 
are using a pulsed laser, you can set the number of bitmap files that the system captures when 
performing a still image operation via Set Images function. The µBeam can capture up to 12 still 
images during one session. 

 
Capturing a Still Image 
To capture a still image: 

1. Open the Options menu and select Still Images, or click  on the Control Toolbar. 

 

The image is captured and an icon is placed on the Status Bar. 
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9.3.3 Tile images 

You can view a single still image or all your still images in a matrix (refer to the following  
figure). When viewing the still images in a matrix, you can select a single still image to  
magnify for details.  

 
To view a single still image, click the still image icon on the Status Bar. 
To view the still images in a matrix, open the Options menu and select Tile Images.  
To magnify a still image in a matrix, click one of the tile images. To close the magnified still 
image, click  in the upper right corner of the image window. The still image remains in the 
matrix. 

 
 

 

 

 

9.3.4 Close All Images 
 

When you close a still image you must either save it or discard it. If you close a still image matrix 
and choose to save it, each of the images in the matrix are saved as separate bitmap files. The 
bitmap filenames are created by the µBeam system and consist of the image number, day, hour, 
minutes and seconds (n_ddhhmmss.bmp). 

 
To close an opened still image or still image matrix: 

1.Click  in the upper right corner of the image window. The Still Image window displays. 

2.If you want to save the still image, click Yes in the Still Image window. 

 
Close All Images option is selected from Options menu, or by the keyboard shortcut Ctrl+F6. 
When this option is selected a message box is displayed: 
 

   
 
To save all open images press "Yes" and the related BMP file will be saved immediately.  
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9.3.5 Save Image file 
Save Image File enables the user to save a screen graphics into either a BMP file or a JPG 
file, in order to edit/print it at a later stage. 
 
Save Image File can be selected from Options menu. 
Once this function is selected, the software opens a sub-menu including: 
 

  
Save Frame: saving only the displayed image screen at the View Area. 
Save Full Screen: saving the full screen presentation. 

 
 
 
 
 
 
 
 
 
 
9.3.6 Save Snapshot 
Snapshot enables viewing a saved snapshot file, or closing a snapshot file and returning to a real 
time measurement mode. 
To view a Snapshot File: 

- Select Snapshot option. The Load Snapshot File window displays. 

- Select a snapshot file.  

- Click Open. The snapshot file displays. 

To close a Snapshot File: 
- Select Snapshot option. The system restores real-time measurement displays. 

Alternatively, press the X sign at the right top corner of the Windows screen application.  
 
 
 
 

9.3.7 Save Data in Text file… 
The system allows you to save the numerical values of the Horizontal and Vertical profiles for 
later analysis. 
 
To save the numerical data of the profiles: 
- From the Options pull-down menu select the Save Profiles as Text file option. 
- Input a file name via the open dialog Save/Print Text file. The data will be saved as a text file 

with the relative Horizontal and Vertical intensity vs. pixel number. The setup data will be 
saved at the same time. The data file is stored with an extension of “TXT”. 

- To view the data, press File menu, View File option, select the text file and double click on 
the desired TXT file. If you want to print this file when open, press Print. An example of a 
saved profile text file as follows: 

 
              *** MicroBeam USB Measurement system, Version2.0 *** 
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UserName:   
UserData:  
Date:  01 Oct 2011 
Time:  17:25:56 
Serial number: 0013 
Size:                    720x576 
Average:             20 
Gain:                   6 Db 
Shutter:              1/500 sec 
Optical Factor:    10 
Horizontal Scale:  0.5101473 (micron/pixel) 
Vertical Scale:      0.5615108 (micron/pixel) 
No#           Horizontal    Vertical 
              (%)            (%) 
 1            0.00          2.07 
 2            0.00           2.07 
 3            0.00           2.07 
 4            0.00           2.07 
 5            0.00          2.07 
 6            0.00           2.49 
 7            0.00           2.49 
 
 

 
 
 
9.3.8   Freeze Mode 
 
Freeze Mode can be selected from Options menu, or by the keyboard shortcut Ctrl+F, or via the 
Control ToolBar. This function freezes on the screen the last image and its measured data. It is 
possible to perform further analysis on the last measurement using Analysis function, such as: 
measure distance between any two points using line function, or performing a Pass/Fail test for 
various beam parameters. It also enables the user to explore the last measurements in detail.  
 
When the µBeam is in freeze mode, a message displays on the top left-hand side of the screen, 
which reads: Freeze Mode. 

 

To freeze the screen graphics: 

1. Open the Options menu and select Freeze Mode, or Click  on the Control Toolbar. A 

Freeze Mode message appears on the menu bar. 

 
To return to real-time measurement mode: 

1. Open the Options menu and select Freeze Mode, or Click  on the Control Toolbar. The 

Freeze Mode message disappears from the menu bar. 

 
 
 

9.3.9 User Data 
User Data enables the user to insert any information required during the measurement 
session, which does not exceed 60 characters. 
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User Data can be selected from Options menu. 
 

  
 
After inserting the user data information and pressing OK button - the information inserted will 
automatically be displayed at the Title Bar, just right to the system name. 

New! It is possible to scan a bar-code using a barcode reader connected to the system, 
and after performing the scan the barcode will be displayed at the User Data field and 
later on at the Title Bar. 
 
 
 
 
 
 

9.4 Settings Menu 
Settings menu allows the user to activate the various settings operations. 
 
The following commands and menu items are available: 
 

   
 

System Setup 

Hardware Setup 

Video Properties 

Offset 
 
 
 
 

9.4.1 System Setup 
System Setup allows the user to configure the µBeam measurements to suit a particular 
set of needs. 
 
System Setup is selected from the Settings menu and includes the Settings options and 
Profiles options. 
 
Settings Options Tab 
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Average 

Zoom (beam/axes stabilize) 

Color 
Set Images (Pulsed laser) 

 

Average 
Average function is used to smooth the data display of quickly varying sources. 
 
Average can be set via System Setup. 
 

   
When using a beam with significant amount of jitters, it is sometimes convenient to set Average 
On. 
When Average in On, a few successive measurements are averaged and displayed. The amount 
of successive measurements averaged can be controlled via this option (possible values are 1-
20), where 1 means "no averaging" and each measured value is displayed. 

When, for example, a value of 10 is chosen, ten consecutive measurements are averaged and 
the result is displayed. When an eleventh measurement is taken, the first measurement value is 
dropped and the second through the eleventh are averaged, etc. 

Because a successive averaging technique is employed, the window display update rate is only 
slightly affected, if at all. 

Upon activation, a few consecutive measurements are averaged and displayed. The amount of 
consecutive measurements averaged can be controlled by this option. 

 
Follow the steps for setting Average: 

Check Box Average button to activate/deactivate the Average On/Off setting. 



Beam User Manual  55  

Input value for Average using the data entry box, set the required Average level by  

Value Setting. 

The Average setting is displayed at the Status Bar. If one rests the mouse cursor at the status bar 
and double clicks on the mouse left button – the system setup screen will open-up to enable a 
faster method to update this parameter. 

 

            Zoom 
 
The Zoom command provides a graphics zoom of the image data displayed in the View Area. 
The beam image can be zoomed by 100% (no zoom), 200%, 400%, 800%, 1600% and 3200%. 
When zooming in and out, the plot will center as closely as possible over the current cross hair 
cursor position. 
Zoom is controlled by a set of 3 tool buttons at the Toolbar: Zoom In, Zoom Out and Axes/Beam 
stabilize. 
 

   
 
At zoom levels above 100%, scroll bars will be displayed on the right and bottom sides of the 
contour and 3D plots. The slide bars allow positioning of the zoom area. 
To choose the Zoom command, select ToolBar. 
The small red arrow-head marks will show the beam centroid location at both X and Y axes. 
When using a big magnification factor these arrow head marks are very useful for finding the 
beam location over the entire displayed image. 
 
The Zoom function can also be selected by choosing the Zoom icon button from Control 
Toolbar.  

Choosing this Zoom icon button causes the Zoom function to Zoom In. 
 

Choosing this Zoom icon button causes the Zoom function to Zoom out.  
  
 

 

Color 
Color can be set via System Setup. 
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Activate this option in order to toggle between full color presentation or B/W presentation (mono) 
of the graphical presentation’s background color. 
    
 
NOTE: White color means "local saturation." The red color stands for the beam highest intensity. 

 
 

Set Images 
Sets the number of still image bitmap files that the system takes during pulsed laser operations. 

If, for example, you input 4 and select the still image function, the system captures and saves the 
next 4 still images.  

The set images function is disabled for continuous lasers.  

To set the number of still image bitmap files, enter a set image value. Possible values are 
1 - 12. 

Upon selecting the required parameter value, press OK to confirm the selection, press Cancel to 
abort. 

Profiles tab 

 
The following setup screen is used to input the Profiles Setup information. 

 
 
Type: Toggle between Sum Profile and Line Profile.  This setting can also be made via 
the ToolBar. See detailed description in section 8.2.1. Each image is a digital 
representation of the spatial power distribution across the beam. The numerical value of 
the profiles width can be viewed in the Profile Measurement Area. 
 
Clip Levels: Set any one of the 3 displayed and calculated clip levels for the beam profile 
presentation. Clip level defines the percentage of the peak of the intensity profile at which 
the width of the beam is measured. For instance, a clip level of 50% indicates that the 
beam width is to be measured at its full width at half maximum (FWHM). A clip level of 
13.5% would measure the beam width at a point, which is 13.5% of the peak of the profile 
and corresponds to the 1/e² point of a Gaussian profile. 
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The three clip levels appear in the V Profile and H Profile displays and are represented 
by horizontal dashed lines that are superimposed on the profile. The user may choose to 
change any one of the three to a new clip level leaving the other two unchanged. 
 
Set the value for the clip level either via the Profiles Setup screen, or graphically by 
placing the mouse cursor at the clip level line: once this is done a double-headed arrow 
cursor appears on the profiles display, drag the clip level line up or down until the desired 
level is reached. 
 
Rotate Angle: Set the view angle (angle of rotation) at which the X Y cross section 
profiles are cut. The rotation angle can be set in 0.1° steps. Also it is possible to set the 

rotation angle via the ToolBar, using the tool button . Here one can input the 
rotation angle in +/- 0.5° steps. Press the Up or Down arrows while watching the rotation 
Operation on the screen. 
 
View: Set Gaussian presentation On or Off, also set the Autoscale value On and Off. 
Autoscale On : Displays the profiles using the full height of the profile window. 
Autoscale Off:  The beam peak can be observed as it changes. This feature is important 
for a focusing process. The peak intensity changes may be observed as a function of the 
focus, showing the variations in beam peak with respect to the changes in beam size. 
 
Gausian On The Gausian fit profile shows how closely the measured beam profile 
matches a Gaussian profile. The Gaussian fit profile is displayed on top of both the 
vertical and horizontal profiles in red. 
The Gaussian Fit is a least-squares fit of a Gaussian equation to the cross section beam 
profiles. The correlation coefficient is the normalized sum of the fit residuals. The 
following equation is used for the Gaussian Fit calculation: 
 

I = Ve ^ {-(x-c)/σ }² 
Where 
 
I = the intensity of a pixel at location x 
V = the maximum intensity of the fitted Gaussian curve 
C = the center of the Gaussian fit peak (centroid) 

 σ = the radius of the Gaussian fit curve at the 1/e² intensity level (diameter) 

 
 
 

 
 
The Gaussian function determines how closely the measured beam profile matches a 
Gaussian profile. When Gaussian is activated, a Gaussian profile is overlaid on to the 
actual measured profile in real time. The theoretical Gaussian profile is displayed in red 
color over the actual measured profile, displayed in white color.  
There are two vertical measures, which can be moved manually by the user. This is a 
useful feature for checking beam size at various points of interest. 
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The percent correlation factor with the Gaussian profile, as well as width comparisons at 
the three-selected clip levels is displayed. 
 

 
 
 
 
 
 

Position Tab 
 

 
 
The following options are available: 
 

 Data (Absolute or Relative) 

 Radius On/Off 
 

Date  
The Data field enables toggling between Absolute and Relative settings. The absolute 
setting is the default and in this case all the position measurements are done with respect 
to the origin (0,0). 
When Relative is set then all the position centroid measurements are made relative to 
any other pre-defined point over the View Area, this point is user-selectable. 
The relative point is set by graphically moving the Cross Line coordinates, the location of 
the Cross Line determines the relative center point. 
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Radius  
  The Radius field enables toggling between Radius calculation On and Off (calculation is 

with respect to the Cross Line center). 
  In case Radius is On then for each one of the active regions of interest, a third parameter 

line appears marked as “R” and it stands for the Radius calculation (squared-root of 
X²+Y²).  

 

 
 
 

 
9.4.2 Hardware Setup 
This option can be activated from Settings menu. It contains all hardware related 
parameters settings of the system. 

 

 
 

 

Hardware Settings 
This option can be activated from Hardware Setup window. 
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Standard: 
 NTSC Use this setting with NTSC (US compatible) video equipment. 
 PAL Use this setting with PAL (European standard) video equipment. 

Input: 
 Composite Use this setting for the RCA-style video connector. 
 S-Video Use this setting for the S-Video input connector. 
 MXC Use this setting for the 8-pin connector of the µBeam measuring head.  

Gain    Controls the µBeam's analog gain at 14 levels from 0 Db to 28 Db. 
Using the gain function the user can adjust the image quality to prevent beam saturation or a 
weak signal. 

Select a gain value from the Gain Control list menu via the ToolBar button  , or via Hardware 
Setup function, Settings Tab. 
This technology is superior to the Auto Gain technology, since it allows the experienced user to 
define the best gain level, which is appropriate. 
 

 Flip Frame: 
Horizontal setting is useful for capturing mirrored images. Flips the image presentation by 180 
degrees. To flip the image presentation, select Horizontal or Vertical 

  

Shutter:  The built in electronic shutter controls the integration time of each frame. By activating 
the shutter one can control the amount of collected light in a similar way a mechanical shutter 
controls the exposure time in a regular photographic camera. The list box in the Control Toolbar 
allows the user to select the required shutter to prevent saturation and distortion of the measured 
beam. 
 
This option is significant for continuos laser beams only. Possible shutter speeds range from 1/3 
to 1/10000 sec 
Select the shutter value from the shutter slider display at the Hardware Settings menu, or via the 

ToolBar button  . 
 
 
Upon selecting the required parameter value, press OK to confirm the selection, press Cancel to 
abort. 
 
 

Laser Setup 
This option can be activated from Hardware Setup window. Laser setup allows you to specify the 
type of laser used and define the trigger control. 
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Type - select one of the laser types: CW or Pulsed. 
 
 

Trigger Control – This option is enabled only for pulsed laser beams only! 
This is an interactive function which allows setting the level of the Auto Pulse detection. 
Since it is an interactive function, if you get erratic pulses or unstable pulsed captures then lower 
or raise the level accordingly until you are satisfied with the displayed results. 
 
Select the trigger value via the Hardware Setup function, Laser Setup Tab (by moving the slider 
to the right hand side for increasing values). 
Alternatively, one can activate trigger via the ToolBar, when the "Pulsed Laser" is activated, and 
select the trigger level using the slider. 
  

  
 
Upon selecting the required parameter value, press OK to confirm the selection, press Cancel to 
abort. 
 
 

Resolution Setup 
This option can be activated from Hardware Setup window. 
This function enables setting the resolution for the digitized beam images captured by the 
system. 
   
This configuration is only necessary if you are not using the µBeam custom camera. These 
values are the resolution parameters (in microns per pixel) of your non-µBeam camera. 
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The µBeam camera uses the default values shown above. 
 
When setting On the Automatic Settings for MXC Camera option, the system resumes its 
default parameters for the MXC camera used for the µBeam system measuring head. 

Resolution - Typically is determined by the quantity of pixels displayed per line or for a given 
area. Here the user can define the Resolution parameters of his CCD camera. Both the Vertical 
and the Horizontal resolution values should be input, the values are given in microns per pixel. 

Optical Scaling Factor - This function enables optical magnification or reduction of laser 
beams by a factor of 1 to 10. 
Upon selecting the required parameter value, press OK to confirm the selection, press Cancel to 
abort. 
 
 
 

9.4.3 Video Properties 
This option can be activated from Settings menu  

 
   
 
Video Time Limit - Use these settings to cause 
the recording to cease after a specified number of 
the minutes and seconds. 
 
Permanent Video File - This setting allows you to 
specify the file that is used to record video clips 
into. For best results, if you have multiple hard 
drives this file should be located on the fastest hard 
disk drive or the disk drive with the most space. 
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9.4.4 Offset 
 
This function is operative when one selects the Line Profile presentation along with the Centroid 
option. The Offset enables defining a relative point to which the line profile is related to.  

 
This means that you can have a line profile crossing through a center of gravity or being offset 
from center of gravity by a certain amount (defined by Offset). 
The meaning of this feature is that even in an environment where the beam moves the line profile 
will always stay in the same area with respect to the beam centroid. 
Set the amount of Horizontal and Vertical offset enabled by 0.1 degrees via this screen. 
 
 
 

9.5 Help Menu 

The following commands and menu items are available from Help menu: 
 

  
Contents: For help on using help press F1. To access the on-line system Help routine, select 

Contents from the Help menu. The contents topic is organized into topics (Alphabetic order). 
To find specific information fast use the Search for Help On menu item under the Help. 

 

Search For Help On: To find help quickly select Search for Help On from the Help menu. This 
will bring up a list of all the topics in the help system. Type the first few letters of the topic of 
interest. The search engine will automatically select any topic that matches the entry. If no 
entries match your topic scroll through the list to see a find a related topic. 

 

Duma Optronics on the Web…: The Website item in the Help menu will start the default 
browser and connect to the http://www.duma.co.il. 
 

About: The About box is selected from the Help menu. This is your typical Windows about box 
showing copyright and contact information. 
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10.0 Customer Support 
 
Please have your serial number and software version number available before you call, and 
include it on your faxes! This will greatly assist our technical service personnel in helping you 
solve your difficulty! 
 
By Phone 
Please call the Duma Optronics Ltd. at 972-4-8200577 and ask for " Customer Service on the 
MicroBeam USB 2013 ". Our Support Hours are from 9 AM to 5 PM.  
 
By Fax 
If you wish to fax your question, our fax number is available 24 hours a day at 972-4-8204190. 
Please put "ATTENTION: MicroBeam USB Customer Service", on the cover sheet of the Fax. 
 
By Internet 
Email: sales@duma.co.il 
Web: http://www.dumaoptronics.com 
 

 

mailto:sales@duma.co.il
http://www.dumaoptronics.com/

